EVE API 6.3.1 for phpBB 3.0.12

Hereby I’m releasing version 6.3.1 of my EVE Online API for phpBB mod.
The following things have changed:

  • Fully integrated OpenFire support! Can be used on EVE entities, as well as groups. Uses the self-built PHP OpenFire UserService class, more details on this class can be found here.
  • Forum should now properly ask to be set as trusted again when using the ingame browser.
  • AccessMasks should now properly be verified if AccessMask is set higher than default.
  • Made the api key link from eveapi_update.php page listen to the AccessMask set in the ACP.
  • Updated the database to Rubicon 1.1.

Quick how-to on the updating process from 6.3.0;

  1. Uninstall EVE API 6.3.0 from the AutoMOD section of the ACP.
  2. Clear forum cache
  3. Upload and install EVE API 6.3.1 to the AutoMOD section of the ACP.
  4. Clear forum cache again
  5. Go to forum.com/install and select update
  6. Once installed, delete the install folder from your forum
  7. Use AutoMOD to make the required changes to your custom template (if required)
  8. Cycle through each of the EVE API setting pages and save them
  9. Cycle through each of the forum group setting pages and save them
  10. Clear forum cache one last time, and we should be done.

If you’d like to have a bit more insight in this process, please watch the slightly outdated 6.2.0 Installation and Configuration video on Youtube as that video should explain a very similar process. The Youtube videos can be found here.

 

EVE Online topic: https://forums.eveonline.com/default.aspx?g=posts&t=21281
EVE Online forum post: https://forums.eveonline.com/default.aspx?g=posts&m=4269569#post4269569